The HttpsGetEnabled property of ServiceMetadataBehavior is set to true…
The HttpsGetEnabled property of ServiceMetadataBehavior is set to true and the HttpsGetUrl property is a relative address, but there is no https base address. Either supply an https base address or set HttpsGetUrl to an absolute address.
Dieser Fehler tritt auf, wenn kein HTTPS Binding in die übergeordnete Web Seite von Sage 200 Service (z.B. Default Website) definiert ist. Das bedeutet, dass diese Web-Seite nicht für Https (SSL) konfiguriert ist.
Lösung: Hier gibt es 2 Lösungen. Wir empfehlen hier die Lösung 1.
-
Die übergeordnete Web-Seite muss mit einem Server Zertifikat für HTTPS (SSL) eingerichtet werden. Hier kann ein offizielles oder ein Self Signed Zertifikat benutzt werden.
-
HttpsGetEnabled in der Web.Config-Datei von Sage 200 deaktivieren.
Web-Seite mit einem self-signed Server Zertifikat für HTTPS (SSL) einrichten
-
Öffnen Sie unter „Server Manager“ den „Internet Information Services (IIS) Manager“.
-
Wählen Sie den Server-Knoten in der Baumansicht und doppelklicken Sie auf „Server Certificates“ (Server-Zertifikate) in der Listenansicht auf der rechten Seite.
-
Unter „Actions“ klicken Sie bitte auf „Create Self-Signed Certificate…“ wenn Sie kein offizielles Server Zertifikat besitzen. Ansonsten klicken Sie auf „Import“.
-
Geben Sie auf der Folgemaske einen „Friendly Name“ ein, der für die Authentifizierung benützt wird und bestätigen Sie Ihre Eingabe mit „OK“. Bei einem Test Zertifikat kann z.B. „Test Sage200“ eingegeben werden.
-
Selektieren Sie in der Baumstruktur auf der linken Seite die übergeordnete Web-Seite von „Sage200Service[Version]“ z.B. „Default Web-Site“ und klicken dann auf „Bindings“ unter „Actions“ am rechten Seitenrand.
-
Die Maske „Site Bindigs“ erscheint und Sie können auf die Schaltfläche „Add…“ klicken.
-
Selektieren Sie in der Dropdown-Liste „Type“ das „Https“ Protokoll und unter „SSL certificate“ Ihren self-signed Zertifikat. Bestätigen Sie Ihre Einstellungen mit „OK“.
HttpsGetEnabled in der Web.Config-Datei von Sage 200 deaktivieren
-
Öffnen Sie das Installationsverzeichnis von Sage 200 Service (Sage200Service[Version]) z.B. „C:\Program Files (x86)\Sage\Sage 200“.
-
Öffnen Sie die installierte Web.Config-Datei.
-
Unter „<serviceBehaviors>“ setzen Sie den Wert für „httpsGetEnabled“ auf „false“ (siehe folgende Abbildung).
System.ServiceModel.Activation.HttpModule
Dieser Fehler tritt auf, wenn .NET Framework 4 installiert ist und die .NET Framework 3.5WCF-HTTP-Aktivierung aktiviert wird.
Lösung: Öffnen Sie eine Eingabeaufforderung mit Administrator Recht, und gehen Sie ins Verzeichnis zu „%windir%\Microsoft.NET\Framework64\v4.0.30319“.
Führen Sie dort den folgenden Befehl aus: aspnet_regiis.exe -i –enable
Information:
HTTP Error 404.3 / 404.17 – Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
Dieser Fehler kann unter Windows Server 2012 / Windows 8 mit IIS 8 auftreten.
Lösung: Feature „HTTP Activation“ unter .NET Framework 4.5 Advanced Services – WCF Services aktivieren.
HTTP Error 500.19 Internal Server Error ungültige Konfigurationsdaten
Übersicht
Dieser Fehler wird auf Grund einer Konfigurationskonflikt/-fehler angezeigt. Bitte beachten Sie immer der dazugehörigen Fehlercode in der Anzeige. In diesem Dokument werden nur die uns seitens Customer Service bekannten Fehlercodes aufgelistet. Falls Sie Ihren Fehlercode hier nicht finden, bitten wir Sie die folgende URL mit weiteren Fehlercodes und Lösungsvorschlägen zu lesen:
Deutsch: https://support.microsoft.com/de-ch/help/942055
Englisch: https://support.microsoft.com/en-us/kb/942055
Fehlercode 0x80070021
Lösung:
-
Starten Sie den Internetinformationsdienst (IIS) Manager unter Systemsteuerung – System und Sicherheit – Verwaltung.
-
Starten Sie im IIS auf der Server Ebene „Delegierung von Features“ (in Engl. „Feature Delegation“).
-
Selektieren Sie „Module“ und ändern Sie den Status auf „Lesen/Schreiben“ (in Engl. „Read/Write“).
Fehlercode 0x80070005
Ursache: Die Gruppe "IIS_IUSRS" besitzt nicht die entsprechenden Berechtigungen für:
-
die Datei "applicationHost.config" und/oder "Web.config".
-
Anwendung/virtuellen Verzeichnisse von IIS.
Lösung: Gewähren Sie der Gruppe "IIS_IUSRS" die Leseberechtigung für diese Dateien und Anwendungsverzeichnisse. Gehen Sie hierzu folgendermassen vor und führen Sie zuerst diese Schritte für die Datei „Web.config“ aus:
-
Suchen Sie im Windows-Explorer den Ordner mit der Datei "applicationHost.config", die der Website zugeordnet ist. Oder suchen Sie das virtuelle Verzeichnis, welches die Datei Web.config enthält, die der Website/Web-Service zugeordnet ist.
-
Öffnen Sie das Kontextmenü mit der rechten Maustaste auf diese Verzeichnisse, welche die Datei "applicationHost.config" oder Web.config enthalten z.B. „C:\Program Files (x86)\Sage“.
-
Selektieren Sie im Kontextmenü „Eigenschaften“.
-
Wechseln Sie auf die Registerkarte „Sicherheit“ und klicken Sie dann auf „Bearbeiten“.
-
Klicken Sie im folge Fenster auf Hinzufügen.
-
Im Fenster „Benutzer, Computer Dienstkonten oder Gruppen auswählen“ geben Sie im Eingabefeld „[Computername]\IIS_IUSRS“ ein, klicken dann auf Namen überprüfen und bestätigen Sie Ihre Eingabe mit „OK“.
-
Aktivieren Sie die Option „Lesen & Ausführen“ und klicken Sie dann auf „OK“.
-
Im Dialogfeld «Eigenschaften» klicken Sie auf «OK».
Wenn Sie das Konto „Everyone/Jeder“ hinzugefügt und alle Berechtigungen entfernt haben, müssen Sie sicherstellen, dass dieses Konto im Minimum das Leserecht hat.
Fehlercode 0x800700C1
Ursache: Dieses Problem kann auftreten, wenn sich der Bit-Typ (32/64-Bit) des angegebenen Moduls für den Anwendungspool, gegenüber dem Host unterscheidet. Zum Beispiel wenn Sie versuchen, eine 32-Bit-Komponente in ein 64-Bit-Anwendungspool zu laden. Dieses Problem kann auch auftreten, wenn das angegebene Modul beschädigt ist.
Lösung:
-
Stellen Sie sicher, dass das angegebene Modul der gleiche Bit-Typ (32/64-Bit) wie der Anwendungspool hat. Sage 200 Reporting Service läuft wegen Crystal Reports im 32-Bit Modus.
-
Stellen Sie sicher, dass das Modul nicht beschädigt ist und führen Sie evtl. ein Repair des .Net Frameworks durch.
-
Entfernen Sie das beschädigte/fehlerhafte Modul von der Web-Applikation / Web-Service.
-
Starten Sie hierzu den IIS Manager.
-
Markieren Sie auf der linken Seite den IIS Server und starten Sie „Modules“ auf der rechten Seite.
-
Markieren Sie das beschädigte Modul und heben Sie die „Sperrung“ für die darunterliegenden Web-Seiten auf. Klicken Sie hierzu auf „Unlock“ unter Aktion/Actions.
-
Selektieren Sie auf der linken Seite in der Baumstruktur die gewünschte Web-Service/-Applikation und entfernen Sie das fehlerhafte Modul nur für diese Web-Service oder Web-Applikation mit „Remove“.
Wiederholen Sie die Punkte ab 3.4 für die anderen betroffenen Web-Services / Web Applikationen.
HTTP Error 500.21 Internal Server Error ManagerPipelineHandler
Mögliche Ursache:
-
Der Managed Handler wird verwendet, aber ASP.NET ist nicht installiert oder nicht vollständig installiert.
-
Es ist ein Tippfehler in der Konfiguration für die Handler-Modul-Liste vorhanden.
Lösung:
-
Silent repair of the 4.0 .NET Framework
-
for 32 bit servers with .Net Framework version 4.0.30319 run the command (in command prompt):%windir%\Microsoft.NET\Framework\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client /q /norestart
-
for 64 bit servers with .Net Framework version 4.0.30319 run the command:%windir%\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client /q /norestart
-
Or active repair of the 4.0 .NET Framework
-
Systemsteuerung – Programme – Programme und Funktionen
-
Doppel Klick auf “Microsoft .NET Framework 4 Extended“
-
Im Folge Fenster den Repair/Reparatur Vorgang selektieren und bestätigen.
-
Install the ASP.NET version and configure IIS to use it
-
open command prompt (Start -> cmd) and for 32-bit servers run the command%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe /i
-
open command prompt (Start -> cmd) and for 64-bit servers run the command%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe /i
Kommentare
0 Kommentare
Zu diesem Beitrag können keine Kommentare hinterlassen werden.